FLUID EFFECTS

Effect to the last drop: tricks to improve our fluid simulations in any 3D package

STEP-BY-STEP GUIDE
Recreate our cover star in the software on the CD

CD INSIDE
Architectural and car models, Poser assets, Gnomon video training WORTH $627

IN DEPTH: THE MAKING OF CRYYSIS
3DS MAX 2008 - CAUSE FOR ALARM?
WIDESCREEN TFT MONITORS ON TEST
INDUSTRY TRENDS: BRDF SCANNING
WIN ONE OF 50 COPIES OF PFHOE

FREE 40-PAGE TRAINING DIRECTORY INSIDE

3D TRAINING DIRECTORY
CGI'S IVY LEAGUE
WE RANK THE INDUSTRY'S TOP 20 TRAINING BODIES
FULL LISTINGS
KEY DETAILS OF OVER 400 3D COURSES WORLDWIDE

WIN ONE OF 50 COPIES OF PFHOE
Flood control

Flooded cities are a staple of modern Hollywood blockbusters. Discover how to create one of your very own, and still keep simulation time to a minimum, with Fusion CIS’s production-proven methodology

BY MARK STASIUK

e’ve seen it in enough films now to know that water flooding a city - or at least a street - is a staple of modern CG work. In production projects, these are always demanding hero shots involving a lot of layers to get the look just right, but the basic task of creating a fairly realistic fluid and rigid body simulation is straightforward to achieve with a package like RealFlow.

The steps involved in setting up a scene of this type take you on a tour of RealFlow’s core functionality, aiming you to deal with a range of fluid simulation shots - from a raft on a river, to a major tsunami! In this tutorial, we’ll start with a Maya scene of a city street, and create a plumbing problem that only Super Roto-Rooter Man or Dynamic Dyno-Rod Guy could solve.

As usual in the world of 3D, there are lots of ways to complete the task and plenty of things you should avoid. It’s a common mistake, for example, to do a quick set-up with overly detailed geometry, turn on dynamics for everything, make the solver run super-accurate and pour a massively high-res fluid into the scene.

While this would result in fantastic results, it wouldn’t be feasible in a normal film schedule. Getting this task to the supervisor in a reasonable time without losing your hair involves being judicious and having a workflow that guides you through the process surely and efficiently. To that end, we’ve provided two versions of the street scene: one that contains all the full-resolution geometry, textures and so on, intended for final rendering; and a highly simplified version with unnecessary geometry - such as upper floor windows, wall sconces and prop details - removed, and a few planes added to prevent the water from leaking out of the scene. In this version, we’ve also made sure to triangulate all the geometry and given all the pieces unique names - a requirement of RealFlow.

Our thanks to Steve Moore, Hack Lian Law and Adam Powney for their help in modelling, texturing and lighting the scene, and to 3do2.com and model author stock for the car model used in the simulation. You can find it on the CD, along with a special 20 per cent reader discount on RealFlow 4.3. Full credits can be found on the 3D World website at http://tinyurl.com/2c2shk. But for now, make sure you have RealFlow (a free demo is available from the Next Limit site) and the import plug-in for Maya 8.5 installed, and let’s start work.

Mark Stasiuk is CG supervisor and co-founder of Fusion CI Studios. He supervised fluid teams for Paseand and The Guardian, and has created fluid effects for numerous ads www.fusioncis.com
**STAGE ONE | Setting up the emitters and rigid body dynamics**

01. Open Intersection_rf_optim.mb from the CD in Maya, and click Panels > Perspective > shut Cam to bring the animated camera into RealFlow as well as the geometry. Set the animation time to 300 and playback range to 300. Select File > Export All... and select the 'iD' File type in the Export All Options panel to export the geometry from Maya to a RealFlow scene data (.syd) file. As no objects deform in this scene, leave Export Deformation unchecked.

02. In RealFlow select File > New Project. Right-click the viewport and Add > Add to Global Links to uncheck and disable it, then File > Import > Import object to import the .syd scene you exported from Maya. In the Nodes window select the multiple objects as shown in the screenshot then right-click in the Nodes window and group them: these objects will be moved dynamically. Group the remaining nodes except the camera. These will be static.

03. Next, choose Edit > Add > Daemons and add Drag Force, Gravity and k Volume. Group them, then change the X value for Rotation for the Gravity01 node (in the Node subpanel of Node Params) to -5 to direct the water flow down the street. Select the k_Volume01 node, click the 'Fit to scene' button and then adjust its size so it encloses the space where the water will flow. This will save resources by killing escape particles that are out of view.

04. From Edit > Add > Emitters add two Circle emitters and a Square emitter, and then group them. Place a Circle emitter beneath each manhole cover, and above their blocker planes. Then rotate them to point up and scale them to fit within the pipe. Place the Square emitter behind the car on the side street, just ahead of the blocker plane there, pointing at the car. Scale it up so it'll generate a major cascade for flooding the street.

05. Select the emitters group and in Particles subpanel of Node Params, set Resolution to 0.25, Density to 15000 and Viscosity to 1.0. Select both Circle emitters, then in the Circle subpanel set the Speed to 0 to create bubbles to blow off the manhole covers, and for the Square emitter set Speed to 13. Refer to the screenshot for emitters’ ‘Random’ and ‘VRandom’ values, which create a more natural flow.

06. Next, you need to keyframe the emitters on and off using the ‘Max particles’ parameter. For the manhole_02 Circle emitter, click Max particles then right-click > Add key with a value of 0 on frame 12, add another key to turn it on at frame 15 with a Max particles value of 500 million. We’ve used a really high value to make sure the sim doesn’t stop mid-shot. Repeat this for manhole_01 Circle emitter, but turn it on at frame 79, and at frame 120 for the Square emitter.

07. You can control the water by adding two Planes to block the water from seeping out of the sewer prematurely. Select Edit > Add > Objects > Plane. Scale down and place a plane just below each manhole cover. Keyframe the Simulation parameter from Active at frame 14 to Inactive on frame 15 for the plane at manhole_02, and Active at 79 to Inactive at 80 for the plane at manhole_01.

08. Select both the dynamic and static object groups. In the Node Params subpanel, set Dynamics to 'Rigid body', which triggers a new Rigid body subpanel to appear. In that panel, set Primitive to Mesh, at which point RealFlow will take a few moments to calculate the collision meshes. Finally, select just the dynamic object group and in the Rigid body subpanel change 'Dyn motion' to Yes.
Stage One (Continued) | Setting up the emitters and rigid body dynamics

Now we’ll set the masses of the dynamic objects. This is more about relative masses then getting the values perfect. In the Rigid body subpanel, give the manhole covers an 'a' mass' value of 100, the car (minicooper) 500, and everything else 50. Select the dynamic objects group again, and change the 'a' energy threshold' to 0.1 to reduce jitter in objects that should be static. The higher this value is, the harder you have to nudge objects to move them.

For the newsstand shelves and manhole objects, keyframe their Dyn motion to No at frame 0 so they’ll be stationary until we want them to be moved by the water. Key the manhole covers’ Dyn motion to Yes when the blocking plane (see Step 7) associated with each cover is inactive. Key each of the news objects’ Dyn motion to Yes at frame 210.

Drag everything except the camera from the Nodes panel to the Global Links panel. Nodes placed in Global Links will interact physically with each other. To see the dynamic objects better, customise their display colours by selecting each object, and then in Node Params, click on the colour swatch for the Color parameter to bring up the 'Select color' window.

Select both the dynamic and static groups and in the Particle Interaction subpanel, set 'Collision distance' to 0.03 and Friction to 0.01. Next, adjust the 'Particle force' setting, which magnifies how hard the water pushes on objects. Set it to 10 for the manhole covers and 1000 for the car so it will get washed away. For all the other dynamic objects, set it to 100.

Collision distances

Collision distance is an important parameter for speed and stability. Set it too low, and the solver will have difficulty detecting particle-geometry collisions, so particles may pass through geometry while the solver increases the substeps (and ReaFlow slows down) as it tries to do better. You should set the parameter as large as your grid will allow. If you need to make it smaller, increase the MIN and MAX substeps to catch the collisions, but be prepared for longer times. During testing, set the Collision distance quite large so you can keep the MIN and MAX substeps low for faster tests.

Click the small arrow beside the Simulate button, and choose Options... to open the 'Simulation options' window. Change MIN substeps to 1 and MAX substeps to 30, which are sufficient for this scene. Click the Simulate button and leave it running. This will generate a low-detail version of the water that will run much faster than the final version, but which will still generate the motion of the dynamically controlled objects. Allow the simulation to finish.

Open Intersection.rf_opt.mtl again in Maya, and insert the animation sd file that ReaFlow just produced. Animation curves will be added to all the objects, including the ones driven by the water. Delete the objects Cylinder01, Plane01 and Plane02. For the manhole covers, delete all their keyframes after frame 150 for manhole_2 and after 160 for manhole_1. Export the data from Maya to a new .sd file. The .sd file will contain these animated objects.

Go back to your ReaFlow scene, and then save it to a new file for the high res simulation. Select any of the street objects and press [Delete] and click Yes in the window that opens to remove all the .sd objects from the scene, leaving everything else. Save, then choose File > Revert the file to re-load it. This procedure clears the memory and allows for a clean import. Now import the new .sd file you exported from Maya in Step 15.
Group the objects as in Step 2, and set their Collision distance and Friction, as in Step 12. This time leave Dynamics to No for all objects since there's no need to do any more rigid body calculations. This will speed up the high-res run considerably. Select the emitters and set a higher Resolution value: 1.0 leads to about a million particles in the scene. For our final animation, we used values of 3.0 for the Circle emitters and 1.3 for the Square. Click the Simulate button.

18. Create a new simulation scene by choosing File > New Project and add three Binary Loader emitters. These load in a set of cached particle files. Load in the high-res results from each emitter, to use for meshing, by clicking on the 'Binary sequence' parameter's field and navigating to the particle files. This method allows you to set up the meshing while the hi-res simulation runs, and is non-destructive to your data. You can also import the object .sd file if you wish.

19. In the viewport, right-click and Add > Mesh. Right-click on the mesh objects in the Nodes panel and 'Insert all fluids'. Set the mesh parameters as shown in the screenshot, for both the mesh and the emitters beneath the mesh. For all three emitters set 'Blend factor' to 250 and 'Radius' to 0.012. If you run your sim at lower resolution than us, you should set a slightly higher radius value to cast the particle cloud.

20. Once you are satisfied with the settings, it is time to build meshes from the particles. With the mesh node selected in the Nodes panel, click the 'Build meshes' button from the main toolbar (press [Ctrl] + [Shift] + [M] to generate all the meshes. If the Fluid Sim hasn't finished, you'll have to wait for it before getting all your meshes. Now open 'intersection.r15_start.mb' from the CD in Maya. Import the animation.sd file.

21. Remove the end keyframes for the manhole covers, as in Step 15. Remove all the objects added by the import that are outside the geometry group. Check their animation curves: if any 180-degree rotations occur, correct them using Maya's Euler Filter (Curves > Euler Filters in the animation window). Import the mesh sequence by clicking Next Limit > RealFlow > Mesh Loader. If you press Play you should see the meshes appear and the dynamic objects moving.

22. Apply the water shader already set up in the scene to the meshes, and link the mesh to the streetlights. When rendering dense water meshes, try to find ways like light linking to speed up the render. For a more realistic look, increase the fluid resolution to generate tighter and higher-detail meshes, and take the results to the next level of realism by adding foam and spray. Such effects can be created by additional layers of simulation in a variety of ways, such as through Python scripts.

Free versions of some scripts that do this are available on the RealFlow scripting website (www.nextlimit.com/realscript). That's the end of this walkthrough: experiment for yourself with the RealFlow settings we've shown you, and with the look of the final render.